Warning: Creating default object from empty value in /webroot/e/b/ebill001/primary/www/wordpress/wp-content/plugins/wptouch/core/admin-load.php on line 106
Medisoft | E-Billing Solutions

August 15, 2022

Medisoft

Medisoft and ICD-10

If you have Medisoft v18 or lower, you have been told that you must upgrade to v19 or v20 because your version is not compatible with ICD-10. This has caused a lot of consternation among providers as the upgrade can cost $2500 -$3000. Fortunately, only half of what you have been told is true.

Version 18 and lower are not compatible with ICD-10 for electronic billing purposes. (At least that is what all of the Value-Added Resellers have told us. They have not been able to articulate the actual problem, however.)

While your current version may not allow you to bill ICD-10 codes electronically, an upgrade is not necessary. Medisoft versions 17 and 18 can be re-programmed to be ICD-10 ready and it can be done for a fraction of the cost of an upgrade. Call or email us for more information.